Comments on Don’t use RouterOS DHCP lease scripts to manage DNS

Be civil and read the entire article first. This is not a support forum. Comments from new contributors are moderated. English only.

Leave a comment

Required. Optional. E.g. your homepage, Twitter. or Email required unless anonymous. Not published or shared. Reuse to be recognized as the same commenter.
Plain-text only. Begin lines with a > character to quote.

Jan

Hi,

using your script for a while now, runs quite well.

But my log is flooded with entrys like

"static dns entry changed by xxx"

any way to run the script without entrys to the log?

Those are system-generated log messages. RouterOS doesn’t provide any flags to quiet them or any options to silence one script. You’ve got four options: 1) Disable logging system-wide, 2) Disable logging at the beginning and re-enable it at the end of the script (you might lose other messages), 3) Stop using the script, or 4) Ignore the log messages.