Ctrl blog discussions

Return to Ctrl blog to find something to discuss! Look for the comment button at the bottom of each article.

Top Commenters

  1. Sukil

    #1
  2. Alexey Shpakovsy

    #2
  3. zakius

    #3
  4. Kyle

    #4
  5. superkuh

    #5
  6. Nic

    #6

Recent Comments

New comment on Don’t use RouterOS DHCP lease scripts to manage DNS:

Jay Libove

And here are the lines of my updated script, which checks to see if there already exists a static DNS entry with the correct IP address for each active DHCP lease. This avoids the log filling up (and the static RAM being unnecessarily re-written) with static DNS entries being set for DHCP leases which this script had already added on previous runs.

Thank you for the hint in an earlier comment about how to do this.

> # For DHCP leases with something/anything in the hostname, and an active IP address ...
> :if (([:len $hostname] > 0) and ([:len $hostaddr] > 0)) do={
> :foreach domain in $domains do={
> :local regdomain "$hostname.$domain"
> :set activehosts ($activehosts, $regdomain)

>

> # Only if a DNS entry does not already exist
> :if ([:len [/ip dns static find where name=$regdomain]] = 0) do={
> /ip dns static add name=$regdomain address=$hostaddr comment=$magiccomment ttl=$dnsttl
> } else={
> # But if a DNS entry did already exist, check if its IP address needs to change
> :local statichostnumber [/ip dns static find where name=$regdomain]
> :local hostoldaddr [/ip dns static get $statichostnumber address]
> :if ($hostaddr != $hostoldaddr) do={
> /ip dns static set address=$hostaddr [/ip dns static find name=$regdomain comment=$magiccomment]
> }
> }
> }
> }

>}

New comment on How to auto-lock your computer on a schedule (e.g. at bedtime):

asdfl;kj

Thanks man, this is exactly what I was looking for. All the other sites I've come across are dross and don't offer the solution you did. Thanks for existing and rock on!

New comment on The trouble with decommissioning a used FIDO security key:

Anonymous

I learnd the same. FIDO(2) is a very good Idea, but the most of the Services do not have a function to accept more the ONE Key.

New comment on Don’t use RouterOS DHCP lease scripts to manage DNS:

Jay Libove

Love this script, thank you!

Instead of:

> :local hostaddr [/ip dhcp-server lease get value-name=address $lease]

.. I use:

> :local hostaddr [/ip dhcp-server lease get value-name=active-address $lease]

This way static leases in a waiting/not-active state don't get added to DNS.

I found this slight difference useful for hosts which can connect via two (or more) interfaces each of which has its own IP address, e.g. a notebook computer that is sometimes on the network wired and other times on the network wireless, but only one at a time, and for which only one hostname is desired in DNS (so that, whichever interface happens to be the one that is connected from time to time, just one hostname will always be the right name to use to find the host).

With the original code, which reads the address parameter, static waiting addresses do get added to DNS (and might get added before the other, actually active address, resulting in only the non-active address being put into DNS, I guess because it's found after the actually-active DHCP lease, and it overwrites the DNS entry that the actually active DHCP lease had just been read by the script and written into static DNS).

New comment on How to run Windows 11 in GNOME Boxes (with UEFI and TPM2 emulation):

Rainer

Thanks for this helpful text! It allowed me to get things working. One thing however I'd love to see is a bit of explanation on the RDP-Option with Gnome Connections you refer to, and which you seem to prefer. I can confirm that the "Spice-Client" is extremely instable, so I'd love to use that rdp-based alternative. I know from platforms with native Windows Remote Desktop clients, that you can chose relolutions from the server. However I have not found a way to achieve this with Gnome Connections. Remmina allows it to some degree, but I'd love to see it in the "native" Gnome Connections. Could you add a few sentences - if only a link. I've Googled, of course, however 'Windows - Fedora/Linux - Host - Guest' result in so many cases that I've not found a single page so far that would handle this particular constellation: Windows 11 guest on Fedora (41) host. Thank you for your consideration.

Best

.r.

New comment on The deafening problem with the FreeStyle Libre 3 app for Android:

Philip Jacobs

People have been complaining about this since the app's inception. I've personally complained several times but to no avail. I've never known a company treat it's clients with such distain. Most people just turn the alarms off, which effectively renders this potentially life-saving feature useless. There is no alternative recognised by the health insurance system here in Germany so I have no choice other than to use the Libre3 app.

New comment on A privacy review of Tribler, the onion-routed BitTorrent app:

Anonymous

The token system has been completely removed at some point before 7.14 and it's no longer possible to become an exit node at all. I'm not sure when (or more importantly why) exactly these changes were made as their changelogs are straight up garbage and I gave up digging through github commits and issues after an hour, but I feel like the current version could be worth re-examination. The pre-release version 8.1x even supports BitTorrent v2 which would solve another of Tribler's issues.

New comment on What’s with cp --reflink: failed to clone: Invalid argument?:

Stephen Kestle

Also the 'c' attribute (compression) makes it fail.

In my situation, I was trying to move files between 2 shared folders on Synology DSM (on the same btrfs volume), except one of them was marked for compression. Rather than take compression off the whole shared folder, I targeted the parent folder with "chattr -c".

I wouldn't have though this would prevent the CoW, but it worked fine after that.

New comment on The deafening problem with the FreeStyle Libre 3 app for Android:

Daniel Glasner

When contacting Abbott, tell them you will give their app the lowest rating, post this problem in all relevant forums and suggest people use the competitors instead.

New comment on What to do when a Linux system is running out of available inodes:

mark

Thanks for this post. I was running out of inodes by copying tons of jpegs from motion running on a RPi with camera to my main machine via an rsync cron job and kept getting the 'no space left on device' error. Never thought I'd had to reformat but that is what I'll need to do for this rather extreme disk use case